Beauty Salon α-BET (alphabet)

space001
Blender3d Collada dae modeling Use Papervision3d on Progression3 and 4 http://a-bet.secret.jp/#/access
more whaison works.
whaison space
space002
http://whaison.jugem.jp/ https://jp.pinterest.com/whaison/ https://www.instagram.com/whaison/ https://whaison.amebaownd.com/
https://suzuri.jp/whaison
http://whaison.blogspot.com/
http://whaison.tumblr.com/ http://qiita.com/users/whaison http://www.behance.net/whaison https://github.com/whaison/ https://bitbucket.org/whaison http://serato.com/user/whaison http://whaison.hatenablog.jp/

typo memo
http://d.hatena.ne.jp/whaison/


dayNote
http://www.myspace.com/whaison http://ameblo.jp/whaison/ http://blog.crooz.jp/whaison/ http://blog.crooz.jp/whaisoncafe/ http://nenpyo.org/whaison

fulldisk
http://full.shin-gen.jp/
http://whaison.client.jp/
http://www.dclog.jp/whaison/
featured forums.
space004
forum.unity3d.com/

forums.unrealengine.com.

Progression Forum.

FlashDevelop Forum.

Papervision3D Forum.

FlexUserGroup Forum.

SparkProjectForum.





Twitter







Mobile
qrcode
Calendar
SunMonTueWedThuFriSat
      1
2345678
9101112131415
16171819202122
23242526272829
30      
<< September 2018 >>
New Entries
Archives
Categories
Recent comment
  • FlashDevelopでフォント埋め込み
    感謝!! (12/24)
  • cocos2d-x-3.0rc0 ,c++ ,cpp でTexturePacker で 吐き出した、plist と png でパラパラアニメーションのコード例
    whaison (04/17)
  • Blender2.67にbvh(web上に2500個以上ころがってる)入れてそのBoneオブジェクトをUnity4.0のmecanimで使う
    whaison (08/19)
  • Apple Dev Center 「Certificates, Identifiers & Profiles」で Adhoc をつくってXCode4.6.1でArchiveしてipaを書き出し
    whaison (04/30)
  • Flash CS6でプロパティーパネルで物理演算のジャンプの高さを設定できるCitrus Engine
    whaison (03/01)
  • 「Flash以外、例えばKinectとか」ON TOKYO (会場:高田馬場4-11-8 Floor 6階 ) 短縮URL http://bit.ly/dI0Bfx
    uka (03/02)
  • App Store Review Guidelines アップル社のアプリ審査基準ガイドライン和訳 Apple が 開発者を悩ませ ユーザーをハッピーにしたいガイドライン。w
    whaison (01/25)
  • Unity3d では ADOBE JAPAN OSAKIで行われたFITC 2010 TOKYOでは、 「iOS用にパブリッシュするためには、フリー版ではなくて、有料版を買ってください。さらに追加のパッケージである、"iOS Package (for Development)"を買ってください」とのことだった。
    whaison (01/25)
  • enjoy Adidas-Futsal-Park
    whaison (01/16)
  • MacBookAir にFlashPlayer入れたらなった。Mac Flash Player 10.1/10.2でUstream などでカメラが認識されないバグそんなときはUstreamProducer!でもなくiPhoneだと直ぐにライブ配信できた
    whaison (01/14)
simple sintax high lighter2.0
space003
SyntaxHighlighter2.0用 の貼り付けコード作成する!
Profile
Links
Recommend
Admin
無料ブログ作成サービス JUGEM
Seach this site
            
2017.02.12 Sunday
ソースからPySide2をコンパイルする 2016年8月17日 #PySide #Python

ソースからPySide2をコンパイルする

https://fredrikaverpil.github.io/2016/08/17/compiling-pyside2/

2016年8月17日 #PySide #Python

Linux、Mac OS X、WindowsでPySide2をコンパイルする方法は次のとおりです。

Maya 2017PySide2(2.0.0〜alpha0)がQt 5.6.1 に対してビルドされているので、

このガイドで使用しているQtのバージョンと64ビットPythonのバージョンです

Note#1:これを読む前に、これをすべてスキップして、

あらかじめ構築されたPythonホイールに直接行きたいかもしれません

 

注2:

この記事はPySide2でPython 2.x / 3.5の状態を

明らかにするために2017-01-19で編集されました。

内容

  • Dockerfiles
  • 前提条件
    • OS X
    • Ubuntu 14.04 Linux
    • Ubuntu 16.04 Linux
    • CentOS 7 Linux
    • Windows 10
  • リポジトリを複製する
  • PySide2ホイールを構築する
    • OS X
    • Ubuntu 16.04 Linux
    • CentOS 7 Linux
    • Windows 10
  • ホイールをインストールする
  • プリコンパイルされたホイールに関する注意
  • Travis-CI経由のドッカー製ホイール
  • コメントを閉じる

前提条件

PySide2(または、おそらくQt5?)ではCmake> = 3.0が必要です。あなたはでバージョンを確認することができcmake --versionます。

OS X

Xcodeのコマンドラインツールが必要になります:

xcode-select --install
 
sudo xcodebuild -license

You can view the license agreements in Xcode's About Box, or at /Applications/Xcode.app/Contents/Resources/English.lproj/License.rtf

 

whaisonMacBookAir:~ whaison$ 

再起動かな

ーーーーーーーーーーーーーーーーーーーーーー

whaisonMacBookAir:~ whaison$ brew

/System/Library/Frameworks/Ruby.framework/Versions/2.0/usr/lib/ruby/2.0.0/rubygems/core_ext/kernel_require.rb:55:in `require': cannot load such file -- mach (LoadError)

from /System/Library/Frameworks/Ruby.framework/Versions/2.0/usr/lib/ruby/2.0.0/rubygems/core_ext/kernel_require.rb:55:in `require'

from /usr/local/Library/Homebrew/extend/pathname.rb:2:in `<top (required)>'

from /System/Library/Frameworks/Ruby.framework/Versions/2.0/usr/lib/ruby/2.0.0/rubygems/core_ext/kernel_require.rb:55:in `require'

from /System/Library/Frameworks/Ruby.framework/Versions/2.0/usr/lib/ruby/2.0.0/rubygems/core_ext/kernel_require.rb:55:in `require'

from /usr/local/Library/Homebrew/global.rb:3:in `<top (required)>'

from /System/Library/Frameworks/Ruby.framework/Versions/2.0/usr/lib/ruby/2.0.0/rubygems/core_ext/kernel_require.rb:55:in `require'

from /System/Library/Frameworks/Ruby.framework/Versions/2.0/usr/lib/ruby/2.0.0/rubygems/core_ext/kernel_require.rb:55:in `require'

from /usr/local/Library/brew.rb:15:in `<main>'

whaisonMacBookAir:~ whaison$ 

ーーーーーーーーーーーーーーーーーーーーーー

 

次に、brew経由で簡単にインストールできる以下のパッケージ

brew install qt5 cmake libxslt libxml2

私のシステムにQt 5.6.1-1とcmake 3.5.2がインストールされました。

| whaison | py QY,PySide,(Code InterFace Design) | 18:27 | comments(0) | - | pookmark |
            
2017.02.12 Sunday
Maya2017でつかっている Python 2.7.6やPython 2.7.12にあわせた PySide2と PyQt4

 

Qt4系、Qt5系があるようだが、

Qt5系は、Python3.x のみ対応のようなので、

 

Maya2017でつかっている

Python 2.7.12 なので

Qt4を選択した。

 

PyQy4

https://riverbankcomputing.com/software/pyqt/download

https://sourceforge.net/projects/pyqt/files/PyQt4/

 

PyQt5

https://sourceforge.net/projects/pyqt/files/PyQt5/

 

SIP Download    

https://www.riverbankcomputing.com/software/sip/download

https://sourceforge.net/projects/pyqt/files/sip/sip-4.19/sip-4.19.zip/download

 

 

 

 

mklink python.exe mayapy.exe

mklink C:¥Windows¥System32¥python.exe C:¥Python27¥python.exe

mklink C:¥Windows¥System32¥pythonw.exe C:¥Python27¥pythonw.exe

C:¥Windows¥System32

 

Microsoft Windows [Version 10.0.14393]
(c) 2016 Microsoft Corporation. All rights reserved.

C:¥Windows¥system32>

C:¥Windows¥system32>mklink C:¥Windows¥System32¥pythonw.exe C:¥Python27¥pythonw.exe
C:¥Windows¥System32¥pythonw.exe <<===>> C:¥Python27¥pythonw.exe のシンボリック リンクが作成されました

C:¥Windows¥system32>
 

C:¥Windows¥system32>mklink C:¥Windows¥System32¥python.exe C:¥Python27¥python.exe
C:¥Windows¥System32¥python.exe <<===>> C:¥Python27¥python.exe のシンボリック リンクが作成されました

C:¥Windows¥system32>python
Python 2.7.6 (default, Nov 10 2013, 19:24:24) [MSC v.1500 64 bit (AMD64)] on win32
Type "help", "copyright", "credits" or "license" for more information.
>>>

 


 

 

 

続きはこちら

http://typea.info/blg/glob/2014/08/python-gui-pyqt.html

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

C:¥Program Files¥Autodesk¥Maya2017¥bin¥designer.exe

 

 

not find load the Qt platform plugin "windows" in "". 

Reinstalling The application may fix this problem. 

http://www.tripleboot.org/?p=138

| whaison | py QY,PySide,(Code InterFace Design) | 15:38 | comments(0) | - | pookmark |
            
2017.02.11 Saturday
Mac py QT (キュート) で エラー

Last login: Mon Jan 16 02:15:53 on console

whaisonMacBookAir:~ whaison$ python --version

Python 2.7.10

whaisonMacBookAir:~ whaison$ brew

Example usage:

  brew [info | home | options ] [FORMULA...]

  brew install FORMULA...

  brew uninstall FORMULA...

  brew search [foo]

  brew list [FORMULA...]

  brew update

  brew upgrade [FORMULA...]

  brew pin/unpin [FORMULA...]

 

Troubleshooting:

  brew doctor

  brew install -vd FORMULA

  brew [--env | config]

 

Brewing:

  brew create [URL [--no-fetch]]

  brew edit [FORMULA...]

  https://github.com/Homebrew/homebrew/blob/master/share/doc/homebrew/Formula-Cookbook.md

 

Further help:

  man brew

  brew home

whaisonMacBookAir:~ whaison$ /usr/bin/ruby -e "$(/usr/bin/curl -fsSL https://raw.github.com/mxcl/homebrew/master/Library/Contributions/install_homebrew.rb)"

curl: (22) The requested URL returned error: 404 Not Found

whaisonMacBookAir:~ whaison$ python --version

Python 2.7.10

whaisonMacBookAir:~ whaison$ brew install pyqt --with-python3

Warning: You are using OS X 10.12.

We do not provide support for this pre-release version.

You may encounter build failures or other breakage.

==> Installing dependencies for pyqt: xz, pkg-config, readline, sqlite, g

==> Installing pyqt dependency: xz

==> Downloading https://fossies.org/linux/misc/xz-5.2.1.tar.gz

 

curl: (22) The requested URL returned error: 410 Gone

Trying a mirror...

==> Downloading http://tukaani.org/xz/xz-5.2.1.tar.gz

==> Downloading from https://jaist.dl.sourceforge.net/project/lzmautils/xz-5.2.1

######################################################################## 100.0%

==> ./configure --disable-silent-rules --prefix=/usr/local/Cellar/xz/5.2.1

==> make install

Error: The `brew link` step did not complete successfully

The formula built, but is not symlinked into /usr/local

Could not symlink include/lzma

/usr/local/include is not writable.

 

You can try again using:

  brew link xz

==> Summary

🍺  /usr/local/Cellar/xz/5.2.1: 59 files, 1.6M, built in 3.1 minutes

==> Installing pyqt dependency: pkg-config

==> Downloading http://pkgconfig.freedesktop.org/releases/pkg-config-0.28.tar.gz

==> Downloading from https://pkg-config.freedesktop.org/releases/pkg-config-0.28

######################################################################## 100.0%

==> ./configure --prefix=/usr/local/Cellar/pkg-config/0.28 --disable-host-tool -

==> make

==> make check

==> make install

Error: The `brew link` step did not complete successfully

The formula built, but is not symlinked into /usr/local

Could not symlink .

/usr/local/opt is not writable.

 

You can try again using:

  brew link pkg-config

==> Summary

🍺  /usr/local/Cellar/pkg-config/0.28: 10 files, 600K, built in 7.1 minutes

==> Installing pyqt dependency: readline

==> Downloading http://ftpmirror.gnu.org/readline/readline-6.3.tar.gz

==> Downloading from http://public.p-knowledge.co.jp/gnu-mirror/readline/readlin

######################################################################## 100.0%

==> Downloading https://gist.githubusercontent.com/jacknagel/d886531fb6623b60b2a

 

curl: (22) The requested URL returned error: 404 Not Found

Error: Failed to download resource "readline--patch"

Download failed: https://gist.githubusercontent.com/jacknagel/d886531fb6623b60b2af/raw/746fc543e56bc37a26ccf05d2946a45176b0894e/readline-6.3.8.diff

whaisonMacBookAir:~ whaison$ python --version

Python 2.7.10

whaisonMacBookAir:~ whaison$ which python

/usr/local/bin/python

whaisonMacBookAir:~ whaison$ easy_install pip

error: can't create or remove files in install directory

 

The following error occurred while trying to add or remove files in the

installation directory:

 

    [Errno 13] Permission denied: '

/Library/Python/2.7/site-packages/test-easy-install-50924.pth

'

 

The installation directory you specified (via --install-dir, --prefix, or

the distutils default setting) was:

 

    /Library/Python/2.7/site-packages/

 

Perhaps your account does not have write access to this directory?  If the

installation directory is a system-owned directory, you may need to sign in

as the administrator or "root" account.  If you do not have administrative

access to this machine, you may wish to choose a different installation

directory, preferably one that is listed in your PYTHONPATH environment

variable.

 

For information on other options, you may wish to consult the

documentation at:

 

  https://pythonhosted.org/setuptools/easy_install.html

 

Please make the appropriate changes for your system and try again.

 

whaisonMacBookAir:~ whaison$ brew install sip

Warning: You are using OS X 10.12.

We do not provide support for this pre-release version.

You may encounter build failures or other breakage.

==> Downloading https://downloads.sourceforge.net/project/pyqt/sip/si

==> Downloading from https://jaist.dl.sourceforge.net/project/pyqt/si

##                                                                   ########                                                             ######################                                               ############################                                         #############################################                        ####################################################                 ######################################################               ############################################################         ############################################################################################################################################# 100.0%

==> python configure.py --deployment-target=10.12 --destdir=/usr/loca

==> make

==> make install

==> make clean

Error: The `brew link` step did not complete successfully

The formula built, but is not symlinked into

/usr/local

Could not symlink シンボリックリンク include

/sip

/usr/local/include

is not writable.

 

You can try again using:

  brew link sip

==> Caveats

The sip-dir for Python is

/usr/local/share/sip.

 

Python modules have been installed and Homebrew's site-packages is not

in your Python sys.path, so you will not be able to import the modules

this formula installed. If you plan to develop with these modules,

please run:

  mkdir -p

/Users/whaison/Library/Python/2.7/lib/python/site-packages

  echo '

import site; site.addsitedir("

/usr/local/lib/python2.7/site-packages

")' >>

/Users/whaison/Library/Python/2.7/lib/python/site-packages/homebrew.pth

==> Summary

/usr/local/Cellar/sip/

4.16.9: 10 files, 888K, built in 23 seconds

whaisonMacBookAir:~ whaison$ brew install pyqt5 --with-python --without-python3

Warning: You are using OS X 10.12.

We do not provide support for this pre-release version.

You may encounter build failures or other breakage.

Error: You must `brew link xz pkg-config sip' before pyqt5 can be installed

whaisonMacBookAir:~ whaison$ 

 

---------------------------------------------------------------------------------------------------------------------------------

--------------------------------------------------------------------------------------------------------------------------------

--------------------------------------------------------------------------------------------------------------------------------

------------------------------------   python 2.7.12      installed   ------------------------------------------------------

--------------------------------------------------------------------------------------------------------------------------------

--------------------------------------------------------------------------------------------------------------------------------

--------------------------------------------------------------------------------------------------------------------------------

 

whaisonMacBookAir:~ whaison$ python --version

Python 2.7.10

whaisonMacBookAir:~ whaison$ 

Last login: Sat Feb 11 13:47:12 on ttys006

whaisonMacBookAir:~ whaison$ python --version

Python 2.7.12

whaisonMacBookAir:~ whaison$ Python 2.7.10

--------------------------------------------------------------------------------------------------------------------------------

--------------------------------------------------------------------------------------------------------------------------------

--------------------------------------------------------------------------------------------------------------------------------

 

---------------------------------------------------------------------------------------------------------------------------------

--------------------------------------------------------------------------------------------------------------------------------

--------------------------------------------------------------------------------------------------------------------------------

------------------------------------   brew install pyqt3   ------------------------------------------------------

--------------------------------------------------------------------------------------------------------------------------------

--------------------------------------------------------------------------------------------------------------------------------

--------------------------------------------------------------------------------------------------------------------------------

--------------------------------------------------------------------------------------------------------------------------------

--------------------------------------------------------------------------------------------------------------------------------

--------------------------------------------------------------------------------------------------------------------------------

 

Last login: Fri Feb 10 16:46:34 on ttys003

whaisonMacBookAir:~ whaison$ brew install pyqt3

Error: No available formula for pyqt3 

==> Searching formulae...

==> Searching taps...

==> You haven't updated Homebrew in a while.

A formula for pyqt3 might have been added recently.

Run `brew update` to get the latest Homebrew updates!

whaisonMacBookAir:~ whaison$ brew install pyqt4

Error: No available formula for pyqt4 

==> Searching formulae...

==> Searching taps...

==> You haven't updated Homebrew in a while.

A formula for pyqt4 might have been added recently.

Run `brew update` to get the latest Homebrew updates!

whaisonMacBookAir:~ whaison$ brew install pyqt5

Warning: You are using OS X 10.12.

We do not provide support for this pre-release version.

You may encounter build failures or other breakage.

Error: You must `brew link xz pkg-config sip' before pyqt5 can be installed

whaisonMacBookAir:~ whaison$ brew link xz pkg-config sip

Linking /usr/local/Cellar/xz/5.2.1... 

Error: Could not symlink include/lzma

/usr/local/include is not writable.

whaisonMacBookAir:~ whaison$ brew update

warning: unable to unlink .yardopts: Permission denied

warning: unable to unlink CONTRIBUTING.md: Permission denied

warning: unable to unlink SUPPORTERS.md: Permission denied

fatal: cannot create directory at '.github': Permission denied

Error: Failure while executing: git pull --quiet origin refs/heads/master:refs/remotes/origin/master

whaisonMacBookAir:~ whaison$ 

---------------------------------------------------------------------------------------------------------------------------------

--------------------------------------------------------------------------------------------------------------------------------

--------------------------------------------------------------------------------------------------------------------------------

------------------------------------   python 2.7.12      install   ------------------------------------------------------

--------------------------------------------------------------------------------------------------------------------------------

--------------------------------------------------------------------------------------------------------------------------------

--------------------------------------------------------------------------------------------------------------------------------

--------------------------------------------------------------------------------------------------------------------------------

--------------------------------------------------------------------------------------------------------------------------------

--------------------------------------------------------------------------------------------------------------------------------

other      window

 

Last login: Fri Feb 10 16:46:24 on ttys002

whaisonMacBookAir:~ whaison$ python

Python 2.7.12 (v2.7.12:d33e0cf91556, Jun 26 2016, 12:10:39) 

[GCC 4.2.1 (Apple Inc. build 5666) (dot 3)] on darwin

Type "help", "copyright", "credits" or "license" for more information.

 

>>> import PyQt5

Traceback (most recent call last):

  File "<stdin>", line 1, in <module>

ImportError: No module named PyQt5

 

>>> import PyQt4

Traceback (most recent call last):

  File "<stdin>", line 1, in <module>

ImportError: No module named PyQt4

 

>>> import pyqt3

Traceback (most recent call last):

  File "<stdin>", line 1, in <module>

ImportError: No module named pyqt3

 

>>> import PyQt

Traceback (most recent call last):

  File "<stdin>", line 1, in <module>

ImportError: No module named PyQt

>>> 

 

 

-------------------------------------------------------------------------------------

--------------------------------------------------------------------------------------------------------------------------------

--------------------------------------------------------------------------------------------------------------------------------

------------------------------------   python 2.7.12      install   ------------------------------------------------------

--------------------------------------------------------------------------------------------------------------------------------

--------------------------------------------------------------------------------------------------------------------------------

--------------------------------------------------------------------------------------------------------------------------------

--------------------------------------------------------------------------------------------------------------------------------

--------------------------------------------------------------------------------------------------------------------------------

--------------------------------------------------------------------------------------------------------------------------------

 

/Users/whaison/Downloads/pyqt/

DebugLogger00100_py.shell

DebugLogger00100.py

 

DebugLogger00100.py

http://www.mediafire.com/file/6y8lehl7kuhe7r4/pyqt.zip

 

--------------------------------------------------------------------------------------------------------------------------------

--------------------------------------------------------------------------------------------------------------------------------

--------------------------------------------------------------------------------------------------------------------------------

--------------------------------------------------------------------------------------------------------------------------------

--------------------------------------------------------------------------------------------------------------------------------

 

 

 

 

--------------------------------------------------------------------------------------------------------------------------------

--------------------------------------------------------------------------------------------------------------------------------

--------------------------------------------------------------------------------------------------------------------------------

--------------------------------------------------------------------------------------------------------------------------------

--------------------------------------------------------------------------------------------------------------------------------

 

 

 

 

| whaison | py QY,PySide,(Code InterFace Design) | 17:05 | comments(0) | - | pookmark |