Beauty Salon α-BET (alphabet)

space001
Blender3d Collada dae modeling Use Papervision3d on Progression3 and 4 http://a-bet.secret.jp/#/access
more whaison works.
whaison space
space002
http://whaison.jugem.jp/ https://jp.pinterest.com/whaison/ https://www.instagram.com/whaison/ https://whaison.amebaownd.com/
https://suzuri.jp/whaison
http://whaison.blogspot.com/
http://whaison.tumblr.com/ http://qiita.com/users/whaison http://www.behance.net/whaison https://github.com/whaison/ https://bitbucket.org/whaison http://serato.com/user/whaison http://whaison.hatenablog.jp/

typo memo
http://d.hatena.ne.jp/whaison/


dayNote
http://www.myspace.com/whaison http://ameblo.jp/whaison/ http://blog.crooz.jp/whaison/ http://blog.crooz.jp/whaisoncafe/ http://nenpyo.org/whaison

fulldisk
http://full.shin-gen.jp/
http://whaison.client.jp/
http://www.dclog.jp/whaison/
featured forums.
space004
forum.unity3d.com/

forums.unrealengine.com.

Progression Forum.

FlashDevelop Forum.

Papervision3D Forum.

FlexUserGroup Forum.

SparkProjectForum.





Twitter







Mobile
qrcode
Calendar
SunMonTueWedThuFriSat
1234567
891011121314
15161718192021
22232425262728
293031    
<< December 2019 >>
New Entries
Archives
Categories
Recent comment
  • FlashDevelopでフォント埋め込み
    感謝!! (12/24)
  • cocos2d-x-3.0rc0 ,c++ ,cpp でTexturePacker で 吐き出した、plist と png でパラパラアニメーションのコード例
    whaison (04/17)
  • Blender2.67にbvh(web上に2500個以上ころがってる)入れてそのBoneオブジェクトをUnity4.0のmecanimで使う
    whaison (08/19)
  • Apple Dev Center 「Certificates, Identifiers & Profiles」で Adhoc をつくってXCode4.6.1でArchiveしてipaを書き出し
    whaison (04/30)
  • Flash CS6でプロパティーパネルで物理演算のジャンプの高さを設定できるCitrus Engine
    whaison (03/01)
  • 「Flash以外、例えばKinectとか」ON TOKYO (会場:高田馬場4-11-8 Floor 6階 ) 短縮URL http://bit.ly/dI0Bfx
    uka (03/02)
  • App Store Review Guidelines アップル社のアプリ審査基準ガイドライン和訳 Apple が 開発者を悩ませ ユーザーをハッピーにしたいガイドライン。w
    whaison (01/25)
  • Unity3d では ADOBE JAPAN OSAKIで行われたFITC 2010 TOKYOでは、 「iOS用にパブリッシュするためには、フリー版ではなくて、有料版を買ってください。さらに追加のパッケージである、"iOS Package (for Development)"を買ってください」とのことだった。
    whaison (01/25)
  • enjoy Adidas-Futsal-Park
    whaison (01/16)
  • MacBookAir にFlashPlayer入れたらなった。Mac Flash Player 10.1/10.2でUstream などでカメラが認識されないバグそんなときはUstreamProducer!でもなくiPhoneだと直ぐにライブ配信できた
    whaison (01/14)
simple sintax high lighter2.0
space003
SyntaxHighlighter2.0用 の貼り付けコード作成する!
ブログパーツ-BLOG PARTS.
Profile
Links
Recommend
Admin
無料ブログ作成サービス JUGEM
Seach this site
            
2017.02.12 Sunday
ソースからPySide2をコンパイルする 2016年8月17日 #PySide #Python

ソースからPySide2をコンパイルする

https://fredrikaverpil.github.io/2016/08/17/compiling-pyside2/

2016年8月17日 #PySide #Python

Linux、Mac OS X、WindowsでPySide2をコンパイルする方法は次のとおりです。

Maya 2017PySide2(2.0.0〜alpha0)がQt 5.6.1 に対してビルドされているので、

このガイドで使用しているQtのバージョンと64ビットPythonのバージョンです

Note#1:これを読む前に、これをすべてスキップして、

あらかじめ構築されたPythonホイールに直接行きたいかもしれません

 

注2:

この記事はPySide2でPython 2.x / 3.5の状態を

明らかにするために2017-01-19で編集されました。

内容

  • Dockerfiles
  • 前提条件
    • OS X
    • Ubuntu 14.04 Linux
    • Ubuntu 16.04 Linux
    • CentOS 7 Linux
    • Windows 10
  • リポジトリを複製する
  • PySide2ホイールを構築する
    • OS X
    • Ubuntu 16.04 Linux
    • CentOS 7 Linux
    • Windows 10
  • ホイールをインストールする
  • プリコンパイルされたホイールに関する注意
  • Travis-CI経由のドッカー製ホイール
  • コメントを閉じる

前提条件

PySide2(または、おそらくQt5?)ではCmake> = 3.0が必要です。あなたはでバージョンを確認することができcmake --versionます。

OS X

Xcodeのコマンドラインツールが必要になります:

xcode-select --install
 
sudo xcodebuild -license

You can view the license agreements in Xcode's About Box, or at /Applications/Xcode.app/Contents/Resources/English.lproj/License.rtf

 

whaisonMacBookAir:~ whaison$ 

再起動かな

ーーーーーーーーーーーーーーーーーーーーーー

whaisonMacBookAir:~ whaison$ brew

/System/Library/Frameworks/Ruby.framework/Versions/2.0/usr/lib/ruby/2.0.0/rubygems/core_ext/kernel_require.rb:55:in `require': cannot load such file -- mach (LoadError)

from /System/Library/Frameworks/Ruby.framework/Versions/2.0/usr/lib/ruby/2.0.0/rubygems/core_ext/kernel_require.rb:55:in `require'

from /usr/local/Library/Homebrew/extend/pathname.rb:2:in `<top (required)>'

from /System/Library/Frameworks/Ruby.framework/Versions/2.0/usr/lib/ruby/2.0.0/rubygems/core_ext/kernel_require.rb:55:in `require'

from /System/Library/Frameworks/Ruby.framework/Versions/2.0/usr/lib/ruby/2.0.0/rubygems/core_ext/kernel_require.rb:55:in `require'

from /usr/local/Library/Homebrew/global.rb:3:in `<top (required)>'

from /System/Library/Frameworks/Ruby.framework/Versions/2.0/usr/lib/ruby/2.0.0/rubygems/core_ext/kernel_require.rb:55:in `require'

from /System/Library/Frameworks/Ruby.framework/Versions/2.0/usr/lib/ruby/2.0.0/rubygems/core_ext/kernel_require.rb:55:in `require'

from /usr/local/Library/brew.rb:15:in `<main>'

whaisonMacBookAir:~ whaison$ 

ーーーーーーーーーーーーーーーーーーーーーー

 

次に、brew経由で簡単にインストールできる以下のパッケージ

brew install qt5 cmake libxslt libxml2

私のシステムにQt 5.6.1-1とcmake 3.5.2がインストールされました。

| whaison | py QY,PySide,(Code InterFace Design) | 18:27 | comments(0) | - | pookmark |
Comment




whaisonStudyNoteBook をFaceBookで いいね!





Share |